Act this weekWhat happenedA serious flaw in WordPress lets attackers run their own code on a site's server while WordPress is unpacking a full update, and attacks have already started.
Who is affectedAnyone running a WordPress website on versions 4.7 through 7.1.3, including small business sites, blogs and online stores.
What to do- 1Update your WordPress site to version 7.1.4 as soon as you can.
- 2Ask your web host or developer to confirm the update went through.
- 3Check for administrator accounts, plugins or files you do not recognize.
- 4Have someone review your server logs for odd requests to PHP files under wp-content/upgrade.
Attackers are already going after a serious flaw in WordPress, the software behind a huge number of business websites. Fixes came out on October 28, 2026. Within about a day, security company Wordfence said it had blocked 62,969 attacks aimed at the problem.
What happened
The flaw lets an attacker run their own code on the server that hosts a website. Security people call this remote code execution. It is rated 8.1 on a 10-point severity scale, and it has no CVE number, which is the usual public ID tag for security bugs.
It comes down to how WordPress updates itself. During a full update of its core software, WordPress unpacks the new files into a predictable folder under wp-content/upgrade. That copy includes the WordPress installer. On many servers, that folder can be reached from the web.
Wordfence says an outsider who requests the installer at exactly the right moment can interact with that temporary copy and work toward running code. No login is needed.
Why the attacks started so fast
The window is tiny. Wordfence says it lasts only seconds in normal lab tests, and an attacker has to hit it while WordPress is unpacking an update. So attackers are simply trying over and over. They repeatedly request a file called setup-config.php, hoping to land at the right instant.
Wordfence's Alex Thomas said two of the largest sources kept polling small groups of sites for roughly 14.5 hours. Other sources tried many variations of folder and version names. Not every request used the exact vulnerable path, but he said the steady probing shows attackers quickly understood how the flaw works.
Who it affects
Any WordPress site on versions 4.7 through 7.1.3 is in the affected range. That covers small business sites, blogs and online stores. The fixed version is 7.1.4. Sites already running 7.1.4 have the fix.
A successful attack needs the narrow timing described above, so not every site is equally exposed at every moment. That is not a reason to wait. Attackers are actively trying, and a site that gets taken over can be used to steal data or cause damage.
What to do
The alert box above lists the steps. The short version: update to 7.1.4, have your host or developer confirm it worked, and check for anything you do not recognize, such as new administrator accounts, plugins or files.
What is not known yet
The source material mentions a list of conditions that must be met for an attack to work, but the details are not included. It also does not say how many sites have actually been compromised. The 62,969 figure counts blocked attempts seen by Wordfence, not successful break-ins.
The takeawayIf your site runs WordPress, update it to version 7.1.4 now, because attackers began trying to exploit this flaw soon after the fix came out.